Jump to content

7800 Power woes... And it isn't because of the switch?


CrossBow

90 views

 Share

A 7800 I worked on over a week ago was sent to me for a 'No Power On' condition. There are many reasons for this and I have found over the years two main issues. First is simply a faulty power supply adapter. Given these things are nearly 40 years old it isn't unreasonable to think that the PSUs are nearing their end of life. In fact I've had another client send back their 7800 when it started to develop power on/off issues and found nothing wrong when they were sent back. Sure enough, it was due to a fault power supply. So when speaking to this new client about their 7800, I suggested making sure the PSU was good and if they wanted to try something quick for not too much money, to get a replacement from Best Electronics. So they did...

However, it didn't resolve the issue 😞 . At that point it was decided to send the 7800 to me so that I could look into the issue in more detail. I honestly figured at that point it was either a faulty power switch (Because those original OEM switches are kinda crappy and get corroded internally). Or perhaps a bad 4013 flip flop IC that controls the logic for power on/off status to the system. It is basically the same circuit the 5200 uses with a few less passive components in the mix.

So the 7800 arrived and I first tested it with my PSUs. Sure enough... no power and no amount of massaging the power button would change it either. Took the cover apart and started to look at stuff. First thing I do is short the power switch to absolutely rule it out of the mix. No dice... hmmm. I then started to check for different things off the 4013 IC. Most things checked out, but the return signal from the system back to the 4013 to indicate power status didn't seem to have any activity. According to the 7800 troubleshooting flowchart, it states to replace the 4013 IC at that point. So I removed the original 4013, installed a socket and plugged a new 4013 into place. 

No dice... still no power. I then started to check further along and found that no input voltage was getting sent to the 7805 voltage regulator. The input voltage switching is controlled by both the 4013 and another power transistor (MJE201). The 201 stands proudly on the edge of the mainboard between the heatsink of the voltage regulator and the power input port. Sure enough when checking the readings from it, I found it wasn't switching on to send the input voltage to the original VR.

To test this I then hooked up my bench power supply, set it to 10v and connected it directly to the input pin of the VR and to ground on the main board. Turned on my bench supply and the 7800 came to life. So I knew I had the right component.

So... what was the point of all of this text?! Simple... to document the basic troubleshooting process I went through to identify the problem component. Now, the 201s aren't exactly made anymore but there are equivalents. However, I don't have any of these modern replacements on hand (Because this is only the 2nd time I've had a 201 go bad ever). So I took the 201 off a donor parts 7800 board and installed that. The clients 7800 lived again. 

I also ended up replacing the original VR with a newer 2A output rated one and installed new capacitors and new front panel switches for good measure. Client figured I was already inside the system and for about $10 in parts...why not?

Mainboard picture. New capacitors, new front panel switches, new voltage regulator and replacement MJE201 just to the right of the heatsink near the power plug.

917811235_78_MB_workcomplete.jpg.0b561fd301a1307ae9229bc03808b56b.jpg

 

Donkey Kong PK is a good game to use for burn-in testing as it has a demo mode and uses the pokey chip for new enhanced audio. So it is a good test for everything. And... tons of fun to play too!

78_DK_Burn_in_1.jpg.366e4312d9b455eb59477884b333a12e.jpg

 

This 7800 was cleaned up and is already back in the hands of its owner and ready to be enjoyed and played for many more years to come!

78_Work_Complete.jpg.f4b836c597fb5c5b7ea7ae92a444f384.jpg

 Share

4 Comments


Recommended Comments

I enjoy reading things like this as I do repairs myself as well. 

The most troublesome spots I've had with faulty7800 systems is poor solder joints at the power supply jack and the 7805 VR.  With power supplies I have had more bad experiences with, I assume, broken wires inside the insulation right at the end that plugs into the jack.  Some of them if I bent them a certain way the 7800 sprang to life, once allowed to stretch out straight the 7800 lost power.

This is why I would rather have non working systems to add to my collection over working ones. I get a certain satisfaction out of fixing them that I can't get any other way.  I don't know if it is a sense of pride or the excitement that I accomplished a repair job or both but it is something I enjoy doing and it helps keep my skills in check.  Although I still have a lot to learn.

Link to comment

This particular one, the owner stated it had been working fine and then suddenly it just didn't power on anymore. With flaky power switches, you can start to know something is up because they gradually get worse over time on actually turning the console on/off. But this one was totally dead as a doornail. I had to work my way backwards a bit through the flowchart before I finally found the main culprit.

It was odd though because the 201 seemed to be switching properly when the power button was depressed in that there was a change in voltage from it indicating something. But the actual 7805VR was never getting any input voltage. And since a bad VR wouldn't cause a lack of voltage to it at least, the only other component before the VR is the 201. So yeah, it was a bit odd and at first when I accepted the work request, I figured it was a bad switch, vr, or 7805 in pretty much that order. 

That wasn't the case and is why I decided to talk about it a bit.

 

Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...