Jump to content
Sign in to follow this  
Trellot

Debug Help - No sound (only static) on a 4-switch Vader 2600 unit

Recommended Posts

Hi all,

 

I've recently purchased a 4-swtich 2600 Vader unit but I only get static noise, no sound at all from the unit.  Great video though!  Looking for some suggestions on how to resolve this issue if possible.

 

What I've done:

 

  • Cleaned mainboard top and bottom with alcohol and toothbrush
  • Dismantled and cleaned all the switchs which now work great
  • Electrically tested voltage regulator and power jack (all well within range)
  • Noticed rust under the RF shield and the top and bottom plates had some rust on them which I've abraided away.
  • Tried the sound adjusting coil but got nothing from that
  • Tuned the RF Modulator without success
  • Noticed a rusty base on the RF modulator box so I desoldered it and cleaned it all up (rust on the board underneath which I've also cleaned well)
  • Resoldered the RF modulator but get the same static noise
  • Replaced the sound adjust coil with another working unit (no dice).

Should there be anywhere else that I need to look other than the RF modulator?  I've read that the TIA also manages sound as well?

 

Any suggestions would be appreciated!  As it stands now all is perfect except the static noise I get.

 

Thanks,

 

Trellot

 

Share this post


Link to post
Share on other sites

Look for L101 on motherboard and short across it. If you get sound then it needs replaced.

 

Check L201 and try to adjust it. Can you get a clear sound? Audio frequency from L201 should be 5.5 MHz.

 

Check C206, C207, Q202, and L202. Also check C201. If everything so far checks OK then RF modulator is faulty and needs replaced.

 

Also, turn unit on with a game in and after a few minutes check TIA by touching it. If it gets hotter than other ICs then it may need replaced.

 

Just a guess...do you have another unit you can pull the RF modulator from and try that?

 

I will keep looking for other areas to check. But, yea, TIA provides the two-channel sounds from the system.

Edited by kamakazi20012

Share this post


Link to post
Share on other sites

Hey kamakazi20012,

 

Per the schematic for this Rev 16 board there does not appear to be any component in the 100 range.  However, I performed a short on L202 on the board and immediately got clear game sound although not without anomoly during game play with repeated echos and other weird things.  What would you suggest at this point, change this L202 module?  Also, it appears that even after power down and back up I'm getting sound now.  What would be the reason for this?  Seems I would need to short again to get sound based on my extremely limited knowlege.

 

Thanks for the suggestion, btw!

 

Trellot

Edited by Trellot

Share this post


Link to post
Share on other sites

Try adjusting L202 first. A small Allen wrench can work but be careful as those can crack easily. Turn slowly in either direction. If that doesn't work then replace it.

 

Yea, I think L101 was a typo in the service manual.

Edited by kamakazi20012

Share this post


Link to post
Share on other sites

So, sound is good after jumping L202? If the static returns then replace L202. That would be my suggestion. Sounds like jumping it might have jolted everything else to a working order. I would check those solder joints, too. Age may have deteriorated some solder. It wouldn't hurt to place some fresh solder on those joints.

Share this post


Link to post
Share on other sites

Also, L202 - the schematic shows it as 1.8 or 1.0 mH.  If I were to try to find a replacement part for this, what exactly do I need to look for?  Not really sure how to search for it to be honest.

 

~ Trellot

Share this post


Link to post
Share on other sites

Well...these are the closest I have found.

 

https://www.digikey.com/products/en/inductors-coils-chokes/fixed-inductors/71?FV=1140050%2Cmu1.8µH%7C2087%2Cffe00047&quantity=&ColumnSort=0&page=1&k=Inductor&pageSize=25&pkeyword=Inductor

 

Copy and paste that in your browser of choice. I am still trying to determine the tolerance levels. But it looks like either of the first two might work.

 

If you want to make sure you get the right part contact Video61 or Best Electronics. They may have some as new-old stock. Wouldn't hurt to ask.

Share this post


Link to post
Share on other sites

Any word on how this VCS is doing?

Yes!  Just this last weekend I finally got this system working.  I was in the market for the 1.8mH inductor but was warned away from thinking that was the issue from Best Electronics.  They mentioned I should try replaicing the the two polystyrene sound capacitors on the board which I ordered and replaced.  Didn't solve the problem.  The problem morphed from having only static and not being able to play the games to having good video and sound after performing that short.  But then on games like PacMan Ms. Pacman and Jungle Hunt, etc., the game would perform a sound glitch and freeze or in Jungle Hunt's case would start the game at the aligators but you couldn't play.  So, I then decided to try swapping out chips but they were all soldered down on the main board, sigh! :)  I chose to pull all the chips and socket them for ease of use in the future and it paid off since it ended up being the last chip I socketed, the RIOT chip.  Now the system plays great, although I get a little buzzing noise every once in while during gameplay.  Not sure why that's happening?  I tried adjusting the sound coil and the rf modulator and it makes a little difference but the buzzing just sort of slips in now and then.  Overall, I'm happy the results!  I'll post a pic soon of the finished product! :)

 

~ Trellot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×