Jump to content
Sign in to follow this  
macjax

Atari 400 Keyboard Issue

Recommended Posts

Hello,

 

This is my first post, so I apologize if it's not in the right area. 

I have a Atari 400 computer that I restored and have working with the exception of a keyboard issue. If I boot the 400 with no cartridge, the Memo Pad comes up but I cannot type anything. None of the keys work except the system restart key located on the top right of the keyboard. If I insert a BASIC cartridge, I get the READY prompt but if I press any button on the keyboard, the 400 locks up and the screen kinda gets random horizontal block lines across it. Sorry, it's hard to explain but I can attach a photo. Was hoping someone can point me in the right direction in what IC I should try to replace first? Maybe the POKEY chip but the controller port works as game cartridges seem to work with the controller port #1, which is tied to the POKEY chip.

 

Any help would be greatly appreciated!!

Thanks!!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...