Jump to content

Horizon: Forbidden West Discussions


Recommended Posts

I was very late to the original Horizon game as I didn't even purchase my PS4 Pro until but a few years ago and Horizon was not one of the original games I picked to play until the complete edition was released I think back in like 2019? Anyway, I ended up totally enjoying the game and still consider it to be the PS4 killer app game for that console. 

So naturally I was completely on board when I found out about a sequel being worked on not long after I beat the original game back in 2019. But was sad to learn it would be for the PS5 exclusively. At that time this was true... but that takes us to now.

I was elated when I learned that the game would in fact have a PS4 port as well and bought it on release day to play on my PS4. I've been playing it nearly every night for a few hours since and still haven't beaten the main storyline of the game just yet. Although I know I'm pretty much just one final mission away now.

So... I'm curious if anyone else is playing the game? I've a few things I wanted to mention but would need to preface that it would be SPOILERS!!!!

With that out of the way... lets discuss...

I want to start mainly with some technical issues I have with this game...

- The new Vista locations are both stupid easy and more frustrating than they were in the previous game. Whenever you come across an old decrepit cell tower it was easy to know you were about to start the Vista hunt fun. Luckily I found most of them quite easy to do since all you needed to do was find the remnants of a platform nearby with a broken guard rail and you were pretty much where you needed to be. But then the pixel point accuracy needed to line up everything was a bit much I felt. The last Vista point I think I needed to get was very frustrating to get lined up from ontop of the large tower.

- graphical glitches abound... Now I will state upfront that this game might very well be the best looking console game I've ever set eyes upon. But it does come with a cost and that cost has been for me, weird graphical glitches. The biggest issue has been collision detection issues with Aloy being able to pass through stuff sometimes, or seeing NPCs and monsters glitch in and out of existence before my eyes. The machine monsters are especially annoying because I have had several battle with large machines where I'm running and dodging to save my life and slowly wittling them down on their health and then all of a sudden... they just Poof! Are gone! The music subsides and there is no machine body to be found or even the parts I stripped off during combat have all disappeared?! Another instance I was battling some rebels and machines at a rebel base and the last machine (A scortcher) took a power hit from me and just ended up stuck under the map?! So now I couldn't complete the damn mission because the last machine was stuck under the map out of the way of my weapons. I knew where it was because I could see it under the map ground with my scanner. I ended up reloading from the last save to do this all over.

- What needs to be done and how to do it... is not made very clear. This goes back to several things you do through out the game but here is a great example. Remember the Vista issue I mentioned earlier? Well, that last one you specifically cannot do until towards the very end of the game. There is a tall neck that you encounter pretty much very early on in the game that you also find out later that you cannot do until near the end. I find this frustrating because it means we discover things in a way where you can literally waste hours trying to figure out how to go about completing such a task and then find out much later that you purposely couldn't achieve this task until near the end of the game?! I think it would have been best that they left these out or made them non discover-able until which time you could actually achieve them. 

- Another odd thing that was NOT explained to me was that during one of the Vista hunts I was told by our in game character that I would need to come back later. And then the game pulled up text on the screen showing me how to switch out between the Vista view and normal scanner mode. So I switched over to normal scanner and continued to play. However, when the time came that I could now achieve this Vista hunt I attempted to try and get the Vista mode to come back up on my scanner pressing the direction button that the game told me earlier to use to switch modes...but... it would not switch over?! I ended up going online to see if this was a bug only to discover that to reactivate the Vista mode on my scanner required me to press the Square button on the controller while having my cursor over the Vista marker in the map screen to Activate it?! This is not made clear at all within the game text, especially when you were told previously by the game to use a direction key on the controller to switch modes and that is how you switched over between them earlier.

- Patches... Patches and more patches. This game has received no less than 5 updates since I bought it including a zero day patch. Now, I know this is quite normal for modern releases but it seems to me that each time they patch this game, it screws up something else for me? The first couple of patches didn't seem to cause me any issues but the last few is when many of the above items I've mentioned started to happen with the graphical glitches etc. The irony to this is that each patch mostly has been released to deal with graphical issues others have noticed. Although the ONLY issues I noticed originally besides what I've mentioned was pop in (Pretty standard given the graphics and scale of this game), and areas that aren't lit properly and show up black in shadow that also effect Aloy when she enters them. But those are not nearly as game breaking as what I've mentioned above.

Now what about the rest of the game? I've been enjoying myself playing it despite these issues. But as fine tuned as the original game was, it is frustrating to have all these little things that really detract from the experience as a whole. The story is just as engaging in this sequel as it was in the original and I really like the fact that this sequel is a true sequel in that you have to be pretty familiar with events from the first game and people you met to understand everything in this game that is taking place. They do rehash some of this in places but not nearly with enough detail for someone who hasn't played the first game to fully understand.

I really am impressed with the character animations in this game. Many of those you interact with are some of the best facial and movement animations I've seen in a game to date. The Mocap work here is very impressive! 

The amount of detail in the machines is also staggering. As an example, when some of the larger machines open their mouths (Likely to spew objects at you), you will see gear work that is actually animated and moving! This is something you would only spot for a split second during game play and combat, but that level of detail is there. Other amazing detail is how foliage will move as you walk and sneak your way through in a very convincing manner. Even tracks you leave behind in sand and snow is believable. The only detail I find lacking is actually in the weather as that portion actually feels more tacked on than anything?

The amount of exploration is stupid impressive as well. But it can also lead to some of that frustration I mentioned earlier. Here is an example. There is a side quest you are given where you need to retrieve some items from a fallen soldier. To do this requires you to access an area on the map that is very high up. But again, this is given to you roughly midway through the game. So doing as I always do, I go to that area and explore the crap out of the area. Sure enough I figured out how to get up on a ledge higher up and glide my way to the part of the map where this quest takes place. However, the quest items were nowhere to be found? Confused I reloaded my game to try again in case it glitched up. But still no quest items. I look online and find out that the quest items ONLY appear if you access the area via very specific means and by that, it isn't something you can do until near the very end of the game?! So once again I've been given a task wherein I find a way to accomplish said task only to find out I'm not technically supposed to do this yet but ... you aren't told this in the game. So I'm left stuck wondering what the heck? So yeah... you explore in all kinds of places and I've found many areas that are off map where there are hidden machines to battle and fight and even discovered that those locations were supposed to be off limits to me until the near end of the game. Yet, I found ways to jump and explore to access those areas well in advance. 

So overall..what are my thoughts?

I think the story is excellent, the graphics are amazing and the overall game is a TON of fun to play. But these issues I've spoken of detract greatly in many ways and make this sequel a lot of fun, but it isn't on the same level pedestal as the first game. But I know I will purchase the DLC that I'm sure will come available over the course of this year because I really can't stop playing the game.


See what I'm up to over at the Ivory Tower Collections: http://www.youtube.com/ivorytowercollections


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...