Jump to content

Join the World of Atari!

Sign In or Create Your Atari I/O Account to join the party! Membership is always free! Gain full access to an amazing new retrogaming community with UNLIMITED member features, weekly high score championships, and prizes. Join other friendly retrogamers as we celebrate nostalgia & classic games, from Atari to Nintendo, Sega, TurboGrafx-16 and beyond!

Photo

Atari Super Pong - Black Screen


  • Please log in to reply
9 replies to this topic

#1 RickR

RickR

    The Don

  • Member
  • 5,366 posts

Posted 06 August 2016 - 03:33 PM

I've mentioned it before.  I have an Atari Super Pong, but it only displays a black screen.  I was able to open up the case (yes, I had the correct security screw-bit in my Harbor Freight kit), but everything inside looks nice and clean.  I'm guessing one of the IC's has gone bad. 

 

Well, before I just give up and call this one a nice piece of shelf-fodder (it will look good on a shelf), I thought I'd just ask if anyone here knows what would cause a blank black screen. 

 

 


  • Justin likes this

#2 Rowsdower70

Rowsdower70

    Pear Member

  • Member
  • 2,302 posts

Posted 06 August 2016 - 06:50 PM

You could have the guts out of mine.   Of course, I haven't even had time to test it yet, but its missing a knob anyway. 


  • RickR likes this

"For you - Rowsdower from the 70 - have been appointed Omnivisioner of the Game Grid."  ~ Atari Adventure Square


#3 RickR

RickR

    The Don

  • Member
  • 5,366 posts

Posted 06 August 2016 - 06:52 PM

We DO have a trade in the works!  ;)


  • Justin and Rowsdower70 like this

#4 Rowsdower70

Rowsdower70

    Pear Member

  • Member
  • 2,302 posts

Posted 06 August 2016 - 06:55 PM

Yessir, I'll try to fire it up tomorrow and let you know what happens.


"For you - Rowsdower from the 70 - have been appointed Omnivisioner of the Game Grid."  ~ Atari Adventure Square


#5 chas10e

chas10e

    Pretzel Member

  • Member
  • 454 posts

Posted 06 August 2016 - 07:00 PM

I wished I was more technically proficient. but will try & share my experiances

 

is there sound from the internal speaker ? although I have had two different working consoles with a bad speaker a first sign of life

 

there is a the channel switch ... it cold be gummed up , switching back & forth mey un-gum it enough for a picture

 

there also may be a TV tuner potetiometer in there ... about a minute into this video

 

for a newer TV I dunno if there is a channel tuning thing that might help dial in a picture .... I had a console that only worked on my oldest TV


  • RickR and Rowsdower70 like this

#6 RickR

RickR

    The Don

  • Member
  • 5,366 posts

Posted 06 August 2016 - 07:35 PM

No sound at all.  I've flipped the switch, tried bypassing the power switch, turning the little pots.  I just don't think it's getting a proper start up...maybe the timing crystally thing is off...or the IC itself is bad.  Voltage looks ok throughout.  I think it's just plain dead, Jim. 



#7 RickR

RickR

    The Don

  • Member
  • 5,366 posts

Posted 06 August 2016 - 07:37 PM

I will say that the black screen is beautifully black.  No interference or static.  :emoji-E420: So I've got that going for me. 

 

It's also quite interesting how much this thing looks like the 2600 inside.  The pots are identical.  Layout very similar. 



#8 chas10e

chas10e

    Pretzel Member

  • Member
  • 454 posts

Posted 06 August 2016 - 08:42 PM

yeah with no sound or picture I would check power as you did 

 

got it through the switch, diodes & the transistor & all that ?

 

I have a hard time just tossing stuff ... I'm not sure if there is a boneyard thread going ....

 

if you make an offer on this thing ...

 

http://www.ebay.com/...sd=232010758829

 

I have an extra handlebar for the top he said it worked (powered up) but prolly didn't go all through it 


  • RickR likes this

#9 RickR

RickR

    The Don

  • Member
  • 5,366 posts

Posted 06 August 2016 - 09:37 PM

OMG -- a boneyard is a GREAT idea!

 

I'd be all over that stunt cycle...but shipping is $20! 


  • Rowsdower70 likes this

#10 chas10e

chas10e

    Pretzel Member

  • Member
  • 454 posts

Posted 06 August 2016 - 10:05 PM

OMG -- a boneyard is a GREAT idea!

 

I'd be all over that stunt cycle...but shipping is $20! 

oh it's $11.26 to East Coast ... :(

 

I have 2 differnt models already or I would have snagged it ( + a parts unit with a bad chip , missing speaker & power port )






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users