Jump to content
Sign in to follow this  
RickR

Wanted: ion iCade

Recommended Posts

Anyone have an iCade they'd like to get rid of?  Or maybe you've seen one at your local thrift store?  I'm not having luck finding one locally.  Update:  I found one on craigslist.  See below.

 

Why would a true retrogamer want one of these?  Well, I was thinking I could hack it be be a mini-MAME cabinet!  Skip the ipad part.  I want to take it apart, add a usb joystick adapter, a mini LCD, and possibly a Raspberry Pi to run MAME.  Plan was to document the process here on Atari.io as a blog post. 

 

2011-05-31-icade1-1306848710.jpg

Edited by RickR

Share this post


Link to post
Share on other sites

Found one on craigslist for $20!!

 

My draft plan:

 

1.  Take this thing apart to determine if the controller wiring is usable.

2.  If yes, purchase a USB controller board and wire it up.

3.  Start testing with a laptop.  Does the controller control MAME properly?

4.  If yes....look for an LCD screen that will fit. 

5.  Raspberry Pi purchase and configure. 

6.  Paint the console and put it all together.

 

I have an ancient GPS screen that has component in.  I'm not sure if that will work, and it might be too small (7").  But first things first....

post-41-0-06861600-1438537422_thumb.jpg

post-41-0-26803600-1438537424_thumb.jpg

Share this post


Link to post
Share on other sites

OK, this is getting good.  I took the iCade apart and found gold. 

 

The cabinet came apart very easily.  I placed it aside for later.
post-41-0-60445700-1438546180_thumb.jpg

 

The controller is one sealed casing.

post-41-0-56408100-1438546178_thumb.jpg

 

with a ton of screws:

post-41-0-76857800-1438546182_thumb.jpg

 

Taking that apart reveals pure beauty.  Very nice quality joystick and buttons with lovely colored (easy to trace) wires.  Looks like everything will easily come apart from the little bluetooth board that's the heart of the iCade.  That's garbage now, but it's so cool that it will come apart so easily. 

post-41-0-68601200-1438546184_thumb.jpg

post-41-0-59982100-1438546186_thumb.jpg

 

Now on to the next step...acquiring a USB controller board.  Off to ebay!

Edited by RickR

Share this post


Link to post
Share on other sites

Testing the joystick and the USB adapter. 

 

The joystick connectors fit perfectly fine as-is into the USB adapter! 

post-41-0-11310400-1439956198_thumb.jpg

 

But the buttons do not.  In the Icade, they used this single connector.  The USB adapter expects two wires per button.

post-41-0-31193900-1439956201_thumb.jpg

 

So my idea is to snip the connectors that came with the USB adapter and crimp on these fancy Harbor Freight connectors. 

post-41-0-89094200-1439956203_thumb.jpg

 

Aha!  They fit now.  Just testing one single button for now.

post-41-0-23679100-1439956206_thumb.jpg

post-41-0-33407900-1439956208_thumb.jpg

 

And BOOM, it works in Windows.  Of course I got the joystick wires backwards on the first try.

post-41-0-34011300-1439956210_thumb.jpg

 

Share this post


Link to post
Share on other sites

It is working.  But what a pain in the rear.

 

Getting ROM files onto the Rasp Pi is an ordeal.  For whatever reason, it doesn't like my router and it's really tricky to get it connected.  Once you do, you use an sftp program to move files onto it.  There is a method of using a USB memory stick instead, but it doesn't let you delete anything copied already to the RP. 

 

And that's not the only thing...you have to use MAME version .37B5 rom files.  I guess there is a way to convert more modern rom files, but it isn't easy. 

 

Good news:  This older version (B) of Raspberry Pi does run MAME games with no speed issues at all.  Donkey Kong, Pac Man, Frogger, 10-yard Fight, Berzerk...all that I've tried work fine. 

 

It's perfectly silent.  No moving fans or hard drives. 

 

That is all for now. 

 

Now to figure out how to rotate the display 90 degrees....

Share this post


Link to post
Share on other sites

It's been awhile, but I do have an update.  I have a lot of MAME games working just fine.  Just need to fine tune the button configuration, and I'll be ready to throw this back together. 

 

Some random notes:

 

- Raspberry Pi, while small, is a total pain in the rear end to work with.  Maybe mine is faulty, but it just won't hold a network connection for more than a few minutes.  I've tried different cables and all. 

- Next attempt at a MAME cab will just use a Windows XP setup.  Maybe a small ITX board. 

- I'm not going to spend any more money on a new/bigger screen.  As I said, I hate the rasp pi.  So build what I have and move on.

Share this post


Link to post
Share on other sites

And another update.

 

I've solved my Rasp Pi networking issue.  It was my power adapter!  Underpowered.  I was using a .4 amp adapter.  Switching to a 0.7 amp unit solved the problem!  I don't know what made me think of checking that.  Sometimes I'm convinced it's divine intervention that plants theories. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...